Its Alive!

phil mead

Contributing Member
Member
Those who attended the Fun Run know my car did not make it back home under its own power after lunch on Saturday. Obvious spark issue. Huggy brought me some tools, TFI ok, Coil ok, …..get a trailer! Thanks to Ripper, Dan, Henry, and Doc, for getting the car back to my house safely. O0 Did some test Sunday afternoon and found the MSD box was ok, but no spark signal. (checked with noid light) Checked PIP sensor in dizzy and it was loose and severely worn. Bingo! My new distributor came in yesterday, installed it today, and no spark? After another hour of checking connections I found no ground going to the TFI module. I could not trace wire the full length in the loom so I added a dedicated ground to the TFI and the car started 1st crank. Thanks again for the help Saturday. This club is great!
 

TroyT

Contributing Member
Member
Phil, Glad you got the problem sorted out. I concur that this club is great. O0
 

Ripper

CACC President Kevin Moses
Contributing Member
Glad we could help, and you got your car sorted. I got back and put my car in the garage and still have not touched it to find the miss.
 

Mike Holt

Member
I’m looking at a transmission replacement. It’s been noisy for a while. But, got worse over the weekend. I’m sure it had nothing to do with the way I baby the car!! :burnout::buck2:
 

aspenbubba

Larry White - Troll
Contributing Member
Member
And to add to the woes of those who went on the "Fun Run" I had a problem with what I suspected was an oil leak but John Bissel determined that it was a slow air leak in the cooling system. So he fixed that and he decided to start the car and get it hot so we could see if the car would still spray coolant under the hood . I had not started the car since returning from Rehoboth and when I did he saw that my ignition coil was sparking . I guess I am lucky that I made it home without the car crapping out on me. John ordered a new MSD coil and hopefully it will be here soon . Also lucky to have John willing to bail me out numerous times this summer.
 

Danbo

FFR6198
Contributing Member
Speaking of ignition problems and electrical issues... Had none! ::)

KNOCK ON WOOD!!

Glad everyone got their issues fixed before putting them in hibernation. O0
 
Top